Homepage GitHub

Install legacy v0

Hello!

I just want to make sure I understand correctly…
If I want to install legacy pyuavcan I use
pip install uavcan
Otherwise I use
pip install pyuavcan
for v1

?

BR

That’s right, yes. We are going to change it though:

I noticed that python can was added to legacy driver a while ago. Are the installation options (transport_) explained in
https://pyuavcan.readthedocs.io/en/stable/pages/installation.html available for legacy uavcan as well?

No. There is only one configuration available for the legacy library, which is the default one.